noizZze

Little Luck With Rails 2.1 Yet

Following the concise yet complete instructions on how to start using the Rails 2.1.0 release candidate from the awesome Getting Rails 2.1 RC1 podcast, I gave it a very quick spin today in one of my projects.

Right after the installation one of the gems refused to work. It was HAML – an excellent HTML builder extension – that blamed Rails for not having some hook registration function call. Taking the latest master copy from github of HAML (which is 1.9.0 there at the moment) solved the problem, but then something else jumped out. RSpec doesn’t work very well with Rails 2.1 at its present state, and every controller test was yelling at me.

Let’s say, it was a bad luck and hopefully I’ll do better next time when they finally release the thing. Got back to Rails 2.0.2 for now.